Changes between Version 11 and Version 12 of mycroft_mark-2_gui_qt5.11


Ignore:
Timestamp:
04/17/20 09:15:45 (2 years ago)
Author:
admin
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • mycroft_mark-2_gui_qt5.11

    v11 v12  
    190190* ./kdesrc-build kio
    191191Some of the packages failed to build but they don't seem to be necessary.
     192=== building the failed packages ====
     193probably not necessary but, ...
     194==== polkit-qt-1 ====
     195* export CMAKE_PREFIX_PATH=/opt/Qt5.12:/home/pi/kde/usr
     196* apt-get install libpolkit-agent-1-dev libpolkit-gobject-1-dev
     197* ./kdesrc-build --no-src polkit-qt-1
     198==== libxslt1-dev ====
     199* sudo apt-get install libxslt1-dev
     200* ./kdesrc-build --no-src libxslt1-dev
     201==== kdoctools ====
     202* sudo apt-get install libxml2-utils docbook-xml docbook-xsl
     203* ./kdesrc-build --no-src kdoctools
     204==== libgpg-error ====
     205* sudo apt-get install texinfo
     206* ./kdesrc-build libgpg-error
     207==== gpgme (after libgpg-error) ====
     208* export PKG_CONFIG_PATH=/opt/Qt5.12:$PKG_CONFIG_PATH
     209* sudo apt-get install libassuan-dev
     210* export CFLAGS="-I/home/pi/kde/usr/include"
     211* export LDFLAGS="-L/home/pi/kde/usr/lib"
     212* export QT_SELECT=5
     213* sudo cp /opt/Qt5.12/bin/moc /usr/lib/qt5/bin/moc
     214* ./kdesrc-build --no-src gpgme
    192215
    193216=== build the mycroft GUI ===